iOS 11 にアップデートした iPad で hpb pad for WordPress を使おうとすると、こんなメッセージが表示されてアプリを起動することができなくなっています。

hpb pad はアップデートの必要があります

hpb pad はアップデートの必要があります
App を iOS 11 で動作させるには、デベロッパによるアップデートが必要です。

淡い期待を抱いて hpb pad for WordPress のサイトを開くと、こうなっていました。

hpb pad for WordPress のサイト

2017/08/14 アプリのダウンロード提供は終了しました。
iOS版の動作環境はiOS 10以下です。iOS 11では動作しません。あらかじめご了承ください。

私が知る限り、hpb pad はカスタム投稿タイプに対応した唯一のアプリでした。

提供終了は非常に残念ですね。